Project: Abakus VCL
Bug report

State: All

User infolance palatini
21.Jun.14 23:02
Subject:
Abakus V500b2 VCL on XE5 Error

Description:
vclsmp190.bpl cant be installed because it is not a design time package

Steps to reproduce:
New project or existing project

(1) Add TAbPanel to an existing form
vclsmp190.bpl install error occurs
(2) Add TAbPanel again and no error occurs, program compiles
and runs properly

(3) Close project

(4) Close XE5

(5) Open XE5

(6) Open project
vclsmpl190.bpl can't be installed because it is not a
design time package error occurs and project does not
have the originally saved TAbPanel component on the
form.




User infoadmin
23.Jun.14 18:52
Comment:
Hi,
we tried to reproduce the issue but we can't...
Could you send me some Information about your Installation?
Do you have Delphi, CBuilder or Rad Studio installed?
Did you got any failure message during Abakus Setup?

User infolance palatini
25.Jun.14 16:42
Comment:
Embarcadero® C++Builder® XE5 Version 19.0.14356.6604

This is a properly licensed version of the XE5 starter edition.

I initially installed the trial version and then uninstalled the trial and installed the paid version.

There were no installation errors on either the trial or paid packages.

This error occurs both on my laptop and desktop installations. Both had the trial version installed before installing the paid versions.

I have a 3rd computer which did not have the trial version installed and will test that tonight.

I have also uploaded the error message details when dropping a component on a form in a completely new vcl forms application.

Files:
abakus_error_file.txt (4 kB)

User infolance palatini
26.Jun.14 14:51
Comment:
I have done the install of the licensed version on a third PC. This machine did not have the trial version installed prior to installing the licensed version.

The installation completed without errors.

I was able to load a component on a new vcl form without an error. I was also able to compile run and save this project.

However, when I closed the compiler down, then re-started the compiler, and attempted to load the previously saved program, I received the following error. (see attached)

Files:
abakus_error.jpg (267 kB)

User infoadmin
27.Jun.14 17:07
Comment:
Hi,
would you please...
- uninstall the Abakus VCL
- Search on your HD for files Abk*.*
- Backup These files and then delete them
Start CBuilder and check that there are no Abakus Components available...

Install Abakus VCL registered Version 5.00b2 select only XE5

Try to build a application by means of Abakus Components...

OK? .... please send me a reply...

User infolance palatini
29.Jun.14 17:21
Comment:
Hello I still get the same error as before.

One important item to be aware of. The computer that I have also has the C++ Builder 6 compiler loaded on it AND that compiler also has the 2.5 licensed version of the components (I bought those from you several years ago while at Transistor Devices).

I will try uninstalling the c++ builder version 6 and older components from one of my laptops and try to install the XE5 components again.

User infolance palatini
29.Jun.14 17:51
Comment:
I have taken another computer.

Removed both the C++ Builder compiler and the 2.5 version of Abakus VCL

I have also removed the licensed Abakus components from XE5.

Verified all removals and did a clean boot.

I reinstalled the Abakus components on XE5 and got the exact same error as before.

Is there a manual installation procedure that I could follow?

User infoadmin
30.Jun.14 18:14
Comment:
2 different Version of the Abakus VCL WILL cause Problems....
Did you search/remove all Abk*.* Files after running uninstall Routine?

User infolance palatini
01.Jul.14 5:51
Comment:
Yes...I deleted all Abk files when I deleted the older C++ Builder compiler.

I suggest that the best solution may be a manual installation.

User infolance palatini
01.Jul.14 6:00
Comment:
Please understand that the trial version of the components installed and worked well under XE5.

Only the licensed version generates the error.

User infoadmin
01.Jul.14 12:42
Comment:
That the Trial works..... this make it harder....
For Trial and registered Version only one Project file exists.... only one small difference in one file... but no other lib's are included...
May.... can you uninstall the components again and search the Registry for e.g. "Abakus" .... may there are still old items from CBuilder...

User infolance palatini
01.Jul.14 14:49
Comment:
Yes, I was going to ask about the possibility of something still being left in the registry.

I like the components and have used them in many applications, however, I had to upgrade my compiler to XE5 since Borland C++ was almost 9 years old.

User infolance palatini
01.Jul.14 19:32
Comment:
I think that I may have a "work around" for this problem.

I found that if I receive the error when opening an existing program, I can open up the "install component" dialog. I have found that the Abakus VCL Property editors item is unchecked.

If I check this item, I can then close my program and re-open it or any other program without the error.

(see attached)

Files:
component_install_packages.jpg (117 kB)

User infoadmin
03.Jul.14 9:11
Comment:
Nice to hear that it will work now....
We will try to reproduce the Problem and check what we can do


You are not logged-in
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot upload files in this forum